Reverting to French

Faults and Technical chat for the Citroen Aircross
Post Reply
routemaster1
Posts: 62
Joined: Wed Mar 27, 2019 7:57 pm

Reverting to French

Post by routemaster1 » Fri May 31, 2019 2:34 pm

This issue occurred on a C3. As the C£ Aircross has a lot of commonality, I have posted this here.

Whilst I understand that disconnecting a battery will cause reversions to kph, kilometers, loss of date and time, and reversion to French, I had an incidence today where I left home with everything OK, and when I got to my destination all of the menus and warnings had reverted to French. All of the other parameters were as normal. Not a big issue, but this was the second time it has happened, and I was wondering if anyone else has had this issue. The car is a 19 reg C3 110bhp Flair.


IKP
Posts: 10
Joined: Sat Jul 28, 2018 4:51 pm
Location: Staines-Upon-Thames

Re: Reverting to French

Post by IKP » Sat Jun 01, 2019 7:40 am

Yes.

I have had my C3 Aircross menus and warnings "reset" to French on 2 occasions while driving - on both occasions, when I had accidentality selected an unconfigured profile. To date I have not been able to recall the sequence of key presses on the steering wheel which made the profile change.

Whilst parked, with the engine running simply worked thru' the menu system to select the desired profile to reset.
IKP


C3 Aircross Flair PureTech 130 S&S with Techno HiFi Pack


routemaster1
Posts: 62
Joined: Wed Mar 27, 2019 7:57 pm

Re: Reverting to French

Post by routemaster1 » Sat Jun 01, 2019 7:41 am

This happened to me without any use of the touchscreen!


JohnB
Posts: 81
Joined: Fri Jun 08, 2018 3:52 pm

Re: Reverting to French

Post by JohnB » Tue Jun 04, 2019 11:32 am

Mine did this once but it was when using voice commands - I think I said "tune to preset 2" but it took it as "change to profile 2" and everything went French...
C3 Aircross Flair 1.2 110 Auto with Parking & Family packs & sunroof


aircrossgran
Posts: 3
Joined: Sat Aug 10, 2019 10:13 am

Re: Reverting to French

Post by aircrossgran » Sat Aug 10, 2019 10:15 am

Mine has done this several times but only after an update was done in April which has caused lots of problems with electrical stuff.


Post Reply

Return to “Faults & Technical”