Mycitroen App

All Citroen Aircross related discussions
Beanee687
Posts: 106
Joined: Tue Jan 28, 2020 10:22 pm

Re: Mycitroen App

Post by Beanee687 » Fri Nov 20, 2020 12:05 am

12 Nov was last update.
Go to Playstore.
Once it's open at top of page touch the 3 bars.
On the drop down that opens touch My Apps and Games.
List of apps on your phone will appear.
Scroll down to Mycitroen App.
Under it, it will say when last updated
Touch MyCitroen
Under what's new it will give last update date 12 November.
Touch what's new
On page that opens scroll down to bottom.
App info should say 1.26.2 as version, which is the latest.

User avatar
srperry
Posts: 126
Joined: Fri Mar 01, 2019 10:32 am
Location: Wiltshire, UK

Re: Mycitroen App

Post by srperry » Sat Nov 21, 2020 8:30 pm

Beanee687 wrote:
Wed Nov 18, 2020 7:52 am
New update to version 1.26.2 available today. Says it improves connectivity.
I tried the new version today for the first time; yes, the idiot "programmers" :lol: have improved connectivity so much that it now refuses to connect at all! :(

I have disconnected and reconnected the bluetooth, force-closed the App, emptied the cache etc., and none of it made any difference. Don't the programmers test it at all, before they release it! My phone is a Samsung Galaxy S10 Plus, and it has no problems connecting to anything else. This version is worse than any so far. And when you complain, they just refer you Citroen Support! :(

It's an unfunny joke. I hope the "programmers" are never allowed to program any system on actual cars, especially as we head towards self-driving ones - They'll be crashing all over! :shock:
C5 Aircross PureTech 130 S&S Flair, Tijuca Blue/Black Roof, Metropolitan Grey ambience

JohnLX
Posts: 22
Joined: Sat Nov 14, 2020 11:49 pm

Re: Mycitroen App

Post by JohnLX » Sat Nov 21, 2020 11:31 pm

My app also stopped working after the 12th!
So I deleted and re-installed it and I will try and connect it again in the morning.

The other strange thing was that the 'new' app did not recognize my password, which I had noted down, and I had to renew it - this seems a little bit suspicious to me.

The app also advised me to update the Map.
So I followed the directions to the letter, inserted the USB stick and was eventually told that it was the wrong map version for the hardware.

Any thoughts on the above?
C3 Aircross 110BHP Petrol Manual

User avatar
srperry
Posts: 126
Joined: Fri Mar 01, 2019 10:32 am
Location: Wiltshire, UK

Re: Mycitroen App

Post by srperry » Sun Nov 22, 2020 10:16 am

JohnLX wrote:
Sat Nov 21, 2020 11:31 pm
My app also stopped working after the 12th!
So I deleted and re-installed it and I will try and connect it again in the morning.

The other strange thing was that the 'new' app did not recognize my password, which I had noted down, and I had to renew it - this seems a little bit suspicious to me.

The app also advised me to update the Map.
So I followed the directions to the letter, inserted the USB stick and was eventually told that it was the wrong map version for the hardware.

Any thoughts on the above?
Other than a distinct lack of testing, and arrogance and lack of care of the developers who appear to believe that they can do no wrong, I can't help - but I would be really interested to know if re-installing the App works fro you?

I can say that if these idiots had ever worked fro me in software design, they wouldn't have done so for long!

My problem with reinstalling is that I use the categories for capturing my business mileage for tax reasons, and when you export and re-import the data files, all the attached information such as categories is lost, which means in my case I would have a lot of work to do to re-enter that information - which is a waste of my time, and could easily be avoided by the developers setting up exports of data properly - it's not rocket science!
C5 Aircross PureTech 130 S&S Flair, Tijuca Blue/Black Roof, Metropolitan Grey ambience

JohnLX
Posts: 22
Joined: Sat Nov 14, 2020 11:49 pm

Re: Mycitroen App

Post by JohnLX » Sun Nov 22, 2020 11:42 am

I have just tried it without any luck. The phone reported itself connected by BT but I could not find anything on the cars system to confirm it although I can play audio through it.

When I first installed it the system worked nicely and I just wonder if something has got messed up along the way. While driving around the M25 it decided entirely on its own accord, to switch into profile 2 and make all announcements in French!

So at the moment its back to RTFM to see if its needs a USB cable and/or WiFi connected on an odd day of the week whilst waiting for a full moon!
C3 Aircross 110BHP Petrol Manual

Beanee687
Posts: 106
Joined: Tue Jan 28, 2020 10:22 pm

Re: Mycitroen App

Post by Beanee687 » Sun Nov 22, 2020 1:29 pm

It doesn't need a cable for the use of Mycitroen App, just Bluetooth which should show Citroen when connected. Naturally the ignition has to be on to activate it. Mine became reluctant to connect but telling phone to forget the car and then searching and pairing again fixed that.
If your phone is in the car and Bluetooth is on and paired touching the phone symbol on the touchscreen will show the phone if connected.
ConnectedCAM uses WiFi employing a fairly weak transmission which is part of the camera. It will show ConnectCAMXXXX on your phones WiFi page.
Android Auto to use the nave function requires to be connected by a data/charger cable.

JohnM52
Posts: 45
Joined: Wed Jul 10, 2019 7:50 pm
Location: Kinross-Shire

Re: Mycitroen App

Post by JohnM52 » Sun Nov 22, 2020 6:32 pm

I have version 1.26.2 listed above.
The last connx shows as 18:26 on 05/11/20.
It might work again some some in the future.
C5 Aircross Flair Plus 180 Petrol EAT8, Platinum Grey with Red Accents and Black Roof.
Now swapped to Quadraxer 2 tyres on the 19" wheels.

User avatar
srperry
Posts: 126
Joined: Fri Mar 01, 2019 10:32 am
Location: Wiltshire, UK

Re: Mycitroen App

Post by srperry » Sun Nov 22, 2020 11:24 pm

Update: I logged out of the App, closed the App, emptied the App's cache, restarted the App and logged back in, and it then downloaded from the car - two 'for technical reasons, some journeys have not been recovered' messages and three journeys. I was missing 5 trips so that was right but the error downloading rate is at least as high as it was before the update!

I still think Citroen should sack the developers and hire someone capable of doing the job.
Last edited by srperry on Tue Nov 24, 2020 8:49 am, edited 1 time in total.
C5 Aircross PureTech 130 S&S Flair, Tijuca Blue/Black Roof, Metropolitan Grey ambience

JohnLX
Posts: 22
Joined: Sat Nov 14, 2020 11:49 pm

Re: Mycitroen App

Post by JohnLX » Mon Nov 23, 2020 11:24 am

My app now appears to be up and 'running' after a lot of messing around.

Actions so far include -

1. Update system to 21.08.84.12_NAC-r0 . This was only update that I could find available for my car.

2. Re-installed the app on my phone. The phone does keep a copy of the VIN number etc. so it doesn't completely remove all data and I am not sure how effective a 'new' install is.

3. Delete and renew the Bluetooth link.

4. Make a quick trip to try it out. So I just took a trip to put petrol in and it reported both legs of the journey and that fuel had been added - I hope this is of use to you.

I will keep an eye on it to see if there are any more issues and report them if there are.
C3 Aircross 110BHP Petrol Manual

User avatar
srperry
Posts: 126
Joined: Fri Mar 01, 2019 10:32 am
Location: Wiltshire, UK

Re: Mycitroen App

Post by srperry » Wed Nov 25, 2020 1:48 pm

Another trip made, another 'For technical reasons' message and no recording of trip. 50% failure rate so far on this new, updated comms, version of the App.
C5 Aircross PureTech 130 S&S Flair, Tijuca Blue/Black Roof, Metropolitan Grey ambience

Post Reply