Climate control doesn't retain settings

Faults and Technical chat for the Citroen Aircross
Post Reply
Sailorsam28
Posts: 3
Joined: Sat May 07, 2022 10:56 am

Post by Sailorsam28 » Fri May 13, 2022 4:04 pm

The climate control touchscreen on my newly delivered C3 Aircross Shine Plus works as it should until I switch of the engine and leave the car. When I come back and start the engine, the climate control defaults to a setting of 21˚C and fan speed 4. This is most irritating as it means that I have to reset the controls to my preferred settings every time I get in the car. I understand that at least one other customer at my dealer has reported a similar fault. Is anyone aware of how this can be sorted.

User avatar
Juan Sheet
Posts: 225
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Fri May 13, 2022 4:22 pm

There may well be a firmware update for this.

You should of set up an account with Citroen (https://mycitroen-uk.citroen.com/) where you can obtain system firmware and mapping updates (if you have the Connected Navigation system).

If you have the latest Wave 4 system fitted, then there was a system firmware update released on 22nd April 2022. Your car may still have the earlier March software, which may contain this bug. Anyway if you have the My Citroen App on your smart phone (using your same log in credentials as the website) it will also inform you if there is a software update for your vehicle.
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

hakancan
Posts: 1
Joined: Sun Aug 14, 2022 8:46 pm

Post by hakancan » Sun Aug 14, 2022 8:58 pm

I have the same issue. I installed the firmware update (released on 22nd April 2022), nothing changed. Everytime I start the engine (except the immediate trial starts), the climate control defaults to a setting of 21˚C and fan speed 4. I reported it to the dealer, they said the diagnostics were ok.

User avatar
Juan Sheet
Posts: 225
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Sun Aug 14, 2022 9:16 pm

@hakancan

Better to post this in the main thread where this is being discussed to avoid duplication (link below). Unfortunately there don't seem to be any Moderators here, otherwise the thread would of been merged with the other one by now.

ttps://www.aircrossforums.co.uk/viewtopic.php?p=6048#p6048
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

Courtiers
Posts: 2
Joined: Tue Aug 16, 2022 3:25 pm

Post by Courtiers » Tue Aug 16, 2022 3:47 pm

I too have this problem.
New car collected 18 July 2022
Fault identified soon afterwards and reported to the dealer
After the usual you must be mistaken excuses this is the design etc
We have escalated the problem to Citroen Customer Care UK
Shortly afterwards we received a call from France
After this we were directed to our dealership customer care representative.
We have documented progress on this and communications between the concerned parties
Contacted the dealership today 16 August but the representative is on holiday until next week
The person we dealt with today was reluctant to indentify this as a fault
Watch this space for progress

User avatar
Juan Sheet
Posts: 225
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Tue Aug 16, 2022 6:07 pm

Please post this on the other link in my previous post - we are trying to build up a picture and this is just duplication

viewtopic.php?p=6048#p6048
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

Post Reply