C3 Aircross Engine fault

Faults and Technical chat for the Citroen Aircross
Post Reply
bevvymerchant
Posts: 2
Joined: Fri Nov 12, 2021 5:13 pm

Post by bevvymerchant » Sat Nov 13, 2021 1:47 pm

I have a C3 Aircross Flare1200 reg Sept 2019, Demo with 2700 miles bought from dealership in Sept2020. Early Nov 2020( after about 6 weeks) I started the car from cold, the engine management came on with spanner and wee engine symbol. The engine rev was about 1100 idling ,but not smooth, would not rev and fan came on and stayed on for 5 or more minutes after shutting engine down. Called out Citroen assist, who plugged in diagnostic and got a non specific engine fault code, He got car going but advised to take to dealership, which I did, they looked over did diagnostic, checked plugs and various intake and fuel bits, but no specific answer to prob. Got it back and it ran for about 6 months and did it again, but cleared and ran again ok until yesterday ( seems to be bi-annual), with same issue. I let it sit and eventually got started spanner gone but wee engine light on and got home, 30 miles with no issue, tried it again today and same issue. The dealership I bought it at has closed and my local dealership can't look at it for 2weeks !. All Citroen help numbers are closed till Monday!!. Anyone experienced same engine issue?

Airtool
Posts: 169
Joined: Sat Nov 28, 2020 11:30 am

Post by Airtool » Sat Nov 13, 2021 6:17 pm

It would be interesting what the "non specific engine code " was, for me you either got a code or you haven't.
Also tell dealer car not safe to drive and ask for a loan car until they investigate, surprising how quick they can be.
C3 Aircross Flair 110bhp 2020 grey

Beanee687
Posts: 430
Joined: Tue Jan 28, 2020 10:22 pm

Post by Beanee687 » Sat Nov 13, 2021 8:26 pm

Just out if interest do you have stop/start and us it working.

bevvymerchant
Posts: 2
Joined: Fri Nov 12, 2021 5:13 pm

Post by bevvymerchant » Mon Nov 15, 2021 1:03 pm

Sorry about engine code, I can't remember ( a year ago and I'm old) exactly the number and don't have any record, but I do remember looking it up and it just referred to the engine. This code was given to me by the breakdown service guy from his little machine.
Stop start is working.
Since last post, spoke to Citroen Customer Care and awaiting call back. Operator I spoke to mentioned BSI Software issue and vehicle recall. Also got it started without issue, accept little engine icon stayed on initially, went for drive to Tesco( 1 Mile) no probs, when starting on return from Tesco, little light went off.

Post Reply