C5 Aircross S&S

Faults and Technical chat for the Citroen Aircross
Post Reply
schmoo2k
Posts: 8
Joined: Tue Sep 29, 2020 2:43 pm

C5 Aircross S&S

Post by schmoo2k » Sat Oct 24, 2020 10:14 am

I have a new C5 Aircross and so far it has never done an auto stop / start (the green light just flashes). Initially I put it down to having a week battery, but I have now done some significant journeys, and nothings changed.

Darecki
Posts: 4
Joined: Sat Mar 28, 2020 1:01 pm

Re: C5 Aircross S&S

Post by Darecki » Sat Oct 24, 2020 6:54 pm

Hi.
I’m using C5 aircross a year. As I observed ghere is a lot of conditions which needs to be met, not only level of batery. But one is imoprtant and not described in manual - push break pedal harder when car is stopped, it works:)

Beanee687
Posts: 106
Joined: Tue Jan 28, 2020 10:22 pm

Re: C5 Aircross S&S

Post by Beanee687 » Sat Oct 24, 2020 11:00 pm

On my C3 Aircross the stop start began to not operate. Even after a long run with no loads.
So I put the battery on charge. It then started to work. After a few days it stopped again. So I charged it again. We are talking of only 0.5v difference. This time it has worked every time for the last week, during day journeys with and without Aircon and at night. Longest journey 11 miles only. There are warnings that these batteries need a special charger but I am using a 1960s unit.

Chrislo
Posts: 85
Joined: Thu Sep 05, 2019 8:03 pm
Location: Maidenhead

Re: C5 Aircross S&S

Post by Chrislo » Sun Oct 25, 2020 9:09 am

The stop start on my C3 Aircross is also very intermittent, I've mentioned it on this forum previously! There must be some inherent issue with it, my previous Citroen DS3 stop start worked faultlessly for 6 years, even though I am a fairly low mileage driver. Perhaps the batteries are not up to holding enough charge? Whatever the reason it's most frustrating, my wife's Mini's stop start works all the time, even though her car does very short journeys.
C3 Aircross Flair 130BHP manual - Breathing Blue

Beanee687
Posts: 106
Joined: Tue Jan 28, 2020 10:22 pm

Re: C5 Aircross S&S

Post by Beanee687 » Tue Nov 03, 2020 8:09 pm

Just an update. Since I put my battery on a charge last, the stop start has worked every journey. Setting off from the first start of the day at the first junction it doesn't switch off, bit after that every stop, with or without, Aircon, wipers, lights, radio operating.

schmoo2k
Posts: 8
Joined: Tue Sep 29, 2020 2:43 pm

Re: C5 Aircross S&S

Post by schmoo2k » Wed Nov 04, 2020 12:55 pm

@Beanee687 - what do you use for that battery charge? (its been a long time since I have had a battery charger in my house!)

Beanee687
Posts: 106
Joined: Tue Jan 28, 2020 10:22 pm

Re: C5 Aircross S&S

Post by Beanee687 » Wed Nov 04, 2020 4:11 pm

I have a 1960s charger which seems to do the job.
I read somewhere that it has to be a special charger but mine seems to do the job and the stop start is now working.

Beanee687
Posts: 106
Joined: Tue Jan 28, 2020 10:22 pm

Re: C5 Aircross S&S

Post by Beanee687 » Fri Nov 06, 2020 8:19 pm

Interestingly I re read the mini user manual today. In the S/S section it says to only use a 12v battery charger or damage may result to the system. So my 1960s charger is ok to use.
On the web charger sellers say it has to be a special charger. Some apparently are 12 or 18v
The system is still working properly.

Post Reply