Service error??

Faults and Technical chat for the Citroen Aircross
Post Reply
Cwba1
Posts: 5
Joined: Tue Mar 05, 2019 5:26 pm

Service error??

Post by Cwba1 » Tue Nov 19, 2019 7:44 am

Hi all,

I recently traded in my C3 Aircross for a C5 Flair BlueHDI 130 which, I have to say, I adore. However, after 2200 miles of joyous motoring, its now telling me I need a service in 1500 miles and that starting will be impossible at the same time due to the Adblue needing topping up.

Have never owned a diesel before so Adblue is new to me. The sales person told me dont worry, you dont need to do anything, it will be topped up at your first service which is 16k.

So, is the service indicator an error and is it causing the Adblue warning too? Clearly looking on here, the story about Adblue lasting between services is rubbish but I think my car is lying to me about its state of mind!

Anyone else had a similar thing happen to them? Am going to call the dealer today but just interested if its a known issue.

Finally, roughly how often does Adblue need topping up?

Cheers all,
2019 C5 Aircross Flair 130BlueHDI S&S Cumulus Grey with Black Pack

routemaster1
Posts: 98
Joined: Wed Mar 27, 2019 7:57 pm

Re: Service error??

Post by routemaster1 » Tue Nov 19, 2019 8:19 am

There are a lot of myths and poor knowledge about the Adblue System. I will try to make it simple

Adblue is a solution of urea in water. It is pumped into the exhaust system to lower the level of nitrogen oxides and enables the car to meet Euro 6 requirements.

The tank holds ~17L of Adblue, and is claimed to last 11-12,000 miles. This is not always sufficient to last from one service to another. Contrary to what you have been told, topping up Adblue is not part of the service, although some garages may do it.

It is true what the indicator says. If you do fail to top up, the car will not start. You do not say what the mileage is, but if your car has only covered 2200 miles you have a problem with the Adblue system.

I would suggest you try topping up the Adblue. It only costs ~£10-£12 for 10L. The filler is most likely (on a C5 Aircross) to be next to the diesel filler under the flap. If you find you can't get the full 10L in, there is a fault with the system. If you do get it in, the countdown should reset itself, although it may take a day or so to do so. If it does fail to rest there may well be a fault.

If you do these steps and it still doesn't clear, I would expect that your car needs a new Adblue pump, and as these are not available separately, it will be a new Adblue tank. This should be done under warranty at no cost to you (if you had to pay it would be well over £1000.

If you do take it back to the garage after filling and the warning not clearing and they try to fob you off, the usual advice is to take it elsewhere.

Cwba1
Posts: 5
Joined: Tue Mar 05, 2019 5:26 pm

Re: Service error??

Post by Cwba1 » Thu Nov 21, 2019 7:48 am

Hi Routemaster1, Thank you for your reply, that was very helpful.

Sorry, I should have stated, the car was a new register and has only done 2200 miles in total. Service intervals are 20k miles or 12 months so clearly not due yet.

I spoke to the dealer and she said that the service indicator could well come on if Adblue is required and that 2000 miles is very soon to be needing it but it may be that the car left the factory without a full tank of Adblue, so top it up and see if that resets things and then see how many miles you do before needing another top up. She also suggested you should get around 6-8k miles between top ups with normal use.

So, I bought 10 litres yesterday and the whole amount went in and still isn't full. The service indicator and Adblue indicator are still showing and telling me I have a range of 1500 miles. I get that the tank might have been a bit low but seems unlikely it was nearly empty and that the 10 litres I put in wouldn't have taken it back past the trigger point for the warning message so am thinking there might be a fault.

Either way, I think a trip back to the dealer is probably worth it.

Will let you know what happens.

Cheers,
2019 C5 Aircross Flair 130BlueHDI S&S Cumulus Grey with Black Pack

routemaster1
Posts: 98
Joined: Wed Mar 27, 2019 7:57 pm

Re: Service error??

Post by routemaster1 » Thu Nov 21, 2019 8:24 am

Thanks for the feedback. You have put in more than enough for the system to reset; apparently it sometimes takes a while to register. What is a slightly greater concern is that the service light is on. If the urea level is low I don't think you get a service warning, just the warning light.

Their estimate of 6-8ooo miles is rather low, it should do well over 10000 miles; well, in the case of our C4 Picasso and our now scrapped C3 it certainly was, and this was true from new. I don't know whether the dosing rate (assuming that the pump is functioning correctly) is dependant on miles driven or on how hard it's driven.

If this is the distance yours does on a tank, it isn't exactly expensive, but filling can be a pain if your filler is below the boot floor and you have to empty the boot and remove a spare wheel before you can top up. I would suggest that anyone planning a long continental trip should ensure that they have filled before they go.

JohnB
Posts: 85
Joined: Fri Jun 08, 2018 3:52 pm

Re: Service error??

Post by JohnB » Sat Nov 23, 2019 9:14 am

I went for petrol this time around (never again!) but my last car (Grand C4 Picasso diesel) took several hours (maybe up to a day or even longer?) to register after I'd topped up the AdBlue.
C3 Aircross Flair 1.2 110 Auto with Parking & Family packs & sunroof

Cwba1
Posts: 5
Joined: Tue Mar 05, 2019 5:26 pm

Re: Service error??

Post by Cwba1 » Mon Nov 25, 2019 12:48 pm

Hi,

Yes, that's what I thought, 10L should at least trip the low level sensor back to ok. However, several days later I still have the service indicator message every time I start (now at 1380 miles due) and if i press the service/fault button it also tells me I only have 1500 miles Adblue range so clearly something is amiss.

I have noticed that usually there is a pump working for a few seconds after turning the engine off but that doesn't appear to be happening now, not sure if its related.

Am calling the dealer today to get them to give it a once over. Either way something either mechanical or electronic seems to be faulty so cant hurt.

Will let you know.

Thanks again.
2019 C5 Aircross Flair 130BlueHDI S&S Cumulus Grey with Black Pack

Cwba1
Posts: 5
Joined: Tue Mar 05, 2019 5:26 pm

Re: Service error??

Post by Cwba1 » Thu Nov 28, 2019 9:17 am

Hello,

So, I went to the dealer yesterday and they inspected the car. Not exactly the expert job i was hoping for. Basically, they reset the Adblue warning and checked the fill level and told me to see how it goes. They think if wasnt filled up properly at the factory but to add 10L and it still not be full is a bit worrying.

They said they couldnt reset the service indicator and that it must have been wrongly programmed when made. I asked if that meant it would be flashing at me all the time for the next year and the service manager came out and tried holding the check button down for 10 seconds which re-set the indicator, though now its telling me I need a service in 21500 miles.

I also said that the SOS button was flashing green and red but now it has stopped. They didnt know what that was either though I read somewhere it might be an over the air update. Its stopped flashing now.

I am a little bit amazed at the lack of knowledge from a main dealer, however, all is now ok, I just need to see how many miles I go before I get the adblue warning again.

Thanks again for all your assistance, hopefully I wont be posting about this again, any time soon.

Cheers,
Craig
2019 C5 Aircross Flair 130BlueHDI S&S Cumulus Grey with Black Pack

Cloud9
Posts: 4
Joined: Sat Dec 07, 2019 11:43 pm

Re: Service error??

Post by Cloud9 » Sun Dec 08, 2019 2:52 pm

Hi

I had a similar problem on my C4 Cactus - in fact, the Adblue tank vacuum pump developed a fault and they had to replace the whole tank I believe. This was after less than a year! I have noticed that the Adblue generally needs topping up between servicing as I found it went for between 9000 - 12000 miles before the warning light came on. And yes, the dealers now seem to say it doesn't come included in the service anymore, so it's an extra cost.
The first 3 Citroen diesels I had it was included in the service package!
I think they have wised up to how much it's costing them now..... ;)

This was a factor in my deciding to go back to petrol with my Aircross...... :D

routemaster1
Posts: 98
Joined: Wed Mar 27, 2019 7:57 pm

Re: Service error??

Post by routemaster1 » Sun Dec 08, 2019 9:43 pm

Have you actually had 4 diesel Citroens since 2014? No Adblue (afaik) before that, then only on 2.0HDis. There is no way a full tank of Adblue should last until the service interval on mileage is reached, as the shortest interval now is 16,000 miles.

Cloud9
Posts: 4
Joined: Sat Dec 07, 2019 11:43 pm

Re: Service error??

Post by Cloud9 » Mon Dec 09, 2019 12:30 am

routemaster1 wrote:
Sun Dec 08, 2019 9:43 pm
Have you actually had 4 diesel Citroens since 2014? No Adblue (afaik) before that, then only on 2.0HDis. There is no way a full tank of Adblue should last until the service interval on mileage is reached, as the shortest interval now is 16,000 miles.
No, 3 diesels - a DS3, C4 Cactus and a C3. The only one that didn't have Adblue was The DS.... The other 2 were both 1.6 Blue HDi 100 engines.

I have to say, although the diesels were good engines, the Puretech 110 petrol is way smoother.....

Post Reply