Real time traffic problem

Faults and Technical chat for the Citroen Aircross
steliosnats
Posts: 8
Joined: Sun Sep 20, 2020 11:14 pm

Post by steliosnats » Sun Jul 17, 2022 1:10 pm

Hallo to everyone. I have suddenly a problem.
I have one year more the free subscription for real time traffic. I have this 2 years with no problems.
Suddenly yesterday nothing. The car has internet via Bluetooth. I tried with Hotspot also. Nothing again.

In citroen account says active. In the car internet says available but underneath in the service says no available. I updated the maps to 23 version still nothing. It keeps saying to me to check the status of the service. Any ideas guys??

User avatar
Juan Sheet
Posts: 214
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Sun Jul 17, 2022 1:36 pm

The live services data is received via the car's own Wifi system. If you are in a poor area, coverage may be temporarily interrupted. This can also happen when first starting the engine. Wait for 5-10 minutes and services should come back up again.

Bluetooth connection is for either audio streaming, phone calls, or mobile internet data. What profiles you can use will depend on your smart phone and data connection / signal strength / network coverage.

If you've recently updated the system or the maps, it can take a little while for the module to load and data services to resume.
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

steliosnats
Posts: 8
Joined: Sun Sep 20, 2020 11:14 pm

Post by steliosnats » Sun Jul 17, 2022 1:48 pm

Juan Sheet wrote:
Sun Jul 17, 2022 1:36 pm
The live services data is received via the car's own Wifi system. If you are in a poor area, coverage may be temporarily interrupted. This can also happen when first starting the engine. Wait for 5-10 minutes and services should come back up again.

Bluetooth connection is for either audio streaming, phone calls, or mobile internet data. What profiles you can use will depend on your smart phone and data connection / signal strength / network coverage.

If you've recently updated the system or the maps, it can take a little while for the module to load and data services to resume.
The live service is disappeared for hours. Yesterday I was driving for 7 hours. My signal was foul. The car does not have a Sim, so it needs internet. I gave it via Bluetooth and later with wifi Hotspot from my phone. But still nothing. The service unavailable and the Tom Tom sign disappeared of course

User avatar
Juan Sheet
Posts: 214
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Sun Jul 17, 2022 1:51 pm

If you have the Connected NAV system the car uses onboard Wifi (you can't see it and no intervention is required by you regarding a SIM). It uses the emergency services / SOS modem built into the car.

If you don't know what you have PM me your VIN and I'll check your system. I suspect you have changed internet connection over to Bluetooth and that's is why you have lost services. It is not necessary, but I can check when I have your VIN.
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

steliosnats
Posts: 8
Joined: Sun Sep 20, 2020 11:14 pm

Post by steliosnats » Sun Jul 17, 2022 1:58 pm

I have the connected nav. But on board wifi from where??I am not sure I understand. But I always had internet via Bluetooth.. I had not changed anything lately..I. am sending you the vin

User avatar
Juan Sheet
Posts: 214
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Sun Jul 17, 2022 2:14 pm

Ok, so I can confirm you have onboard WiFI, so you don't need Bluetooth from your phone for live services. The system uses the built in WiFi which is used for making an emergency SOS call or Citroen Service call from the ceiling buttons. These use the in-built modem to do this and the Connected Navigation with Live services uses this connection too. Unlike Citroen and Peugeots of the past, where you had to use a SIM card, this is not required on later vehicles. The system is hidden away and needs no input or SIM card from you.

You need to go through the connection setup and make sure you have it set up correctly.

Have a look at this video. It will show you how to check if your services are active or not and what options to check to make sure the live services can operate correctly.

C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

steliosnats
Posts: 8
Joined: Sun Sep 20, 2020 11:14 pm

Post by steliosnats » Sun Jul 17, 2022 2:18 pm

I will check the video to see what is going wrong

I still can't understand wifi on board. I do not have emergency call button

User avatar
Juan Sheet
Posts: 214
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Sun Jul 17, 2022 3:00 pm

According to your VIN you have WiFi on board. Do you have these in the ceiling compartment in front of the Rear View Mirror?

SOS.PNG

I guess not, as your VIN indicates no independent Telematic unit installed, so that will be why you don't have the emergency / service call buttons.

This is a very odd setup though, I must say. This being the case, then it looks like you will have to use your Smartphone connection for internet services. So check that you have the correct Bluetooth profile installed:

To modify the connection profile:
  • Press Telephone to display the main page.
  • Press the "PHONE" button to access the secondary page.
  • Press "Bluetooth connection" to display the list of paired devices.
  • Press the "Details" button for a paired device.
  • Select one or more profiles
  • Press "OK" to confirm
These are the 3 profiles:
  • "Telephone" (hands-free kit, telephone only).
  • “Streaming" (streaming: wireless playing of audio files on the telephone).
  • "Mobile internet data".
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

steliosnats
Posts: 8
Joined: Sun Sep 20, 2020 11:14 pm

Post by steliosnats » Sun Jul 17, 2022 3:15 pm

All these you said are OK.. as I told before the car has internet from my phone. The emergency button does not exist

Ps. Thanks for your help.. I found the problem!!!!!
In the maps somehow it was unchecked the authorize send information. It was working for 2 years and one day just unchecked...everything works fine. Thank you very much

Ps 2 I have another problem for some months. After one hour one and a half approximately continuous driving Bluetooth just disconnects from phone. And I must switch off engine to connect again. Any ideas for this??

User avatar
Juan Sheet
Posts: 214
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet » Sun Jul 17, 2022 5:21 pm

You have the latest firmware installed and maps, so the problem is likely to be at your phone side of things.

Sometimes they update the phone software which can update the bluetooth profile on the phone and this cause issues with the head unit. A typical example was iPhones with the IOS 11 update some time ago - this caused lots of people headaches, but those on IOS 10 were unaffected.

I use an iPhone with the latest IOS version without issue on my Aircross, but it can depend on the phone and version of operating system you have - Android too.
C3 Aircross Flair 1.5 Blue HDi
Techno Pack / Grip Control / Visio Park

Post Reply