Electric mode

Faults and Technical chat for the Citroen Aircross
Post Reply
Mike96
Posts: 1
Joined: Sun Apr 18, 2021 3:28 pm

Post by Mike96 » Sun Apr 18, 2021 3:37 pm

I have a Citroen c5 aircrosshybrid 2011 flair model and for the 2nd time the power mode switch won't let me select the electric mode,even when I start the car it goes into hybrid mode any answers thanks Mike

Npr1980
Posts: 4
Joined: Thu Jan 14, 2021 7:59 pm

Post by Npr1980 » Sun Jun 27, 2021 11:23 am

Probably a bit late for you now but I think there is a maintenance mode they go into every now and again that prevents electric mode from working while the battery is going through some kind of conditioning routine - happened on mine a couple of months after purchasing and after a decent run on the petrol engine (I think about 40miles or so) electric kicked back in.

Jubbo
Posts: 5
Joined: Tue Jul 06, 2021 7:07 pm

Post by Jubbo » Tue Aug 24, 2021 12:22 pm

Hi there

I would love to know how you resolved this.

I have this exact fault. It is very intermittent. When in fault the car will not go into electric mode, so stays in "hybrid", but does not run correctly, the engine never switches off and therefore the dash reads 0% emission free - which is not normal for "hybrid" driving. It will also consume any battery charge - even though the engine is running full time.

There is no rhyme or reason to when the fault will occur. Sometimes the car is fine for days. Sometimes it stays in fault for 2 weeks. It makes no difference if i am doing short or long journeys. Sometimes the i just need to turn the car off and back on again - other times this doesn't work.

As i type this the car is in with Citroen now - they are working through what it could be.

The whole episode has really put me off Citroen. The fault first appeared after two weeks, i was told to get it booked in - a 4 week wait. Then the day before i was called to confirm the appt and let them know that it's not currently in fault , they said there was no point bringing it in and i should call back when in fault. I did this and was told they could not do anything as they were too busy, i should call back when it is next in fault. I did this, I brought it in and a technician looked at it for 2 mins and basically just said "yup it won't go into electric mode, you will have to book it in" - which i did - and another 4 week wait. Sods law that the car has been in fault for a solid 2 weeks and then 2 days before going into the dealer, it started working again. I learned from my mistakes and just dropped it in - we will see what they find.

I saw the comment about maintenance mode - i highly doubt mine is that. Also, if the car needs to run off petrol every now and then it should be clearly stated on the dash that the car is in maintenance mode and then countdown the runtime or miles until electric can be selected again.

It has been hugely frustrating.

sproaty
Posts: 2
Joined: Tue Dec 14, 2021 8:45 pm

Post by sproaty » Thu Jan 06, 2022 11:25 am

Hi Jubbo,
January now, did you get this resolved, as I have the same issue.
Seems common, but no one knows the fix.
Regards.
Sproaty.

Post Reply